$re = '`<input type="hidden" name="csrftoken" value="(?P<token>.+?)"`m';
$str = '<input type="hidden" name="csrftoken" value="somerandomtokenvalue">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);