import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,3}(?:\\.\\d{1,2})?$";
final String string = "1\n"
+ "12\n"
+ "123\n"
+ "1.2\n"
+ "12.3\n"
+ "123.4\n"
+ "1.23\n"
+ "12.34\n"
+ "123.45";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}