$re = '/^\d{1,3}(?:\.\d{1,2})?$/m';
$str = '1
12
123
1.2
12.3
123.4
1.23
12.34
123.45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);