using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{1,2}[A-Z]{3}(?:\d{2}|\d{4})\b";
string input = @"/AB/25MAR1992/
/AB/25MAR92/
/AB/2MAR92/
/AB/02MAR92/
/AB/02MAR992/
/AB/02MAR992/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}