package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)START
(?:
(?: cat dog bird ) |
(?: cat | dog | bird )
)
END`)
var str = `STARTcatdogbirdEND
STARTcatEND
STARTdogEND
STARTbirdEND
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}