package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(?:\.if|\.else)(.*?)(?:\.else|\.endif)`)
var str = `.if CONDITION1
code1
.elseif CONDITION2
code2
.else
code3
.endif`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}