Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(https?:\/\/)?[0-9a-z-_]*(\.[0-9a-z-_]+)*(\.[a-z]+)+(\/[0-9a-z-_]*)*?\/?$
/
gim
Input 1
1
New
nearform.com graphql-hooks.com nearform.com/ www.nearform.com www.nearform.com/ http://nearform.com https://nearform.com/ http://www.nearform.com https://github.nearform.com/graphql-hooks https://www.fastify.io/ react-js.org