$re = '/^[\w \'-\/]+$/m';
$str = 'Jl. Merpati No. 3 RT/RW 001/012 (Bekas Jalan Manyar)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);