const regex = /(?s)<!-- @\[(?<name>\w+)\((?<type>\w+)\)\] -->\s+# (?<h1>[\w ]+?)\s+<!-- @\[(?<name2>\w+)\] -->\s+## (?<h2>[\w ]+?)\s+```(?<codeType>\w+)\s+(?<code>.*?)```\s+<!-- @\[\/(?<parent>\w+)\] -->/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<!-- @\\[(?<name>\\w+)\\((?<type>\\w+)\\)\\] -->\\s+# (?<h1>[\\w ]+?)\\s+<!-- @\\[(?<name2>\\w+)\\] -->\\s+## (?<h2>[\\w ]+?)\\s+```(?<codeType>\\w+)\\s+(?<code>.*?)```\\s+<!-- @\\[\\\/(?<parent>\\w+)\\] -->', 'gm')
const str = `<!-- @[Hero(super)] -->
# Creating new contexts
<!-- @[UsageExample] -->
## Usage example
\`\`\`javascript
Import { ICON_NAME } from 'Icons'
\`\`\`
<!-- @[/Hero] -->
<!-- @[ArticleSection] -->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}