const regex = /^(\(\d{2,}\) ((\d{4}-\d{4})|(9\d{4}-\d{4})))|(\d{2})((9\d{8})|(\d{8}))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\(\\d{2,}\\) ((\\d{4}-\\d{4})|(9\\d{4}-\\d{4})))|(\\d{2})((9\\d{8})|(\\d{8}))$', '')
const str = `62991788276`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}