import Foundation
let pattern = #"(?<=jw\.load\(\[\{ file: ')http[:\/a-zA-Z0-9_\.]+(?=',)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<html>
<script>
jw.load([{ file: 'http://vrbx105.xxx.xx/U7yvQnLiA_m5mhE9MUHf3w/1477628604/vl107aeb2d7db53f91fc6ad2e76fe11e49.mp4', provider: 'http' }]);
</script>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}