#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=urce>)[\s\S]*?(?<=<\/datas)"
Local $sString = "<id>SomeID</id>" & @CRLF & _
"<datasource>C:/projects/my_project/my_file.jpg</datasource>" & @CRLF & _
"<title>My title can include / and other characters</title>" & @CRLF & _
"<abstract></abstract>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")