# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)\b(Devices|Community String)\b\s*-\s*([\w,\/]+)"
test_str = ("1. What is being changed?\n"
"Add in Solarwinds monitoring the router and switch of the new Store:\n\n"
"Devices - MCHLS5178,sw517801,sr517800,sr517801,sr517802,MCHLS5184,sw518401,sr518400,sr518401,sr518402\n"
"Community String - N/A\n\n\n"
" \n\n"
"2. Where it is being changed?\n"
"Solarwinds monitoring (10.3.4.7)\n\n"
" \n\n"
"3. Why it is being changed?\n"
"To monitor the router and switch of the store 5178,5184\n\n"
" \n\n"
"4. What is the Business Impact of the Change?\n"
"No business impact during implementation.\n\n"
" \n\n"
"5. Who will be doing the change? \n"
"Network team\n\n"
" \n\n"
"6. When is the change happening?\n"
"2020-01-26 01:00:00\n\n"
" \n\n"
"7. Who will be testing the change after implementation?\n"
"Network team")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.