$re = '/(\s+)((?<=\s)[a-z]|^[a-z]).*?([A-Z]?(?<=[a-zA-Z0-9])[a-zA-Z0-9]+)/';
$str = 'do we have a Hashtag
';
$subst = "$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;