re = /(?<!If I )(?:recalls?|recalled)/m
str = 'Hi, I am talking about a recall on the product I bought last month. If I recall correctly, I purchased this at your store on august 15th. Can you tell me if I can get a refund on this recall?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end