use strict;
my $str = 'LEGION T5 (90SV003WGE)
FLEX 5 (82R700BEGE) XKLUSIV
V17-IRU 83A2001NGE
LENOVO E16 G1 21JT000HGE_WIN 11
LENOVO THINKCENTRE M70T 12Q6000AGE I7-12
IDEAPAD 3 17ALC6
TEST 12345ABCDE TEST ZYXWV98765';
my $regex = qr/(?:\b|_)(?!\d+\b|[A-Z]+\b)([A-Z\d]{10})(?:\b|_)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}