package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((8|\+994|\+374|\+375|\+7|\+996|\+373|\+992|\+993|\+998)[\- ]?)?\(?\d{3,5}\)?[\- ]?\d{1}[\- ]?\d{1}[\- ]?\d{1}[\- ]?\d{1}[\- ]?\d{1}(([\- ]?\d{1})?[\- ]?\d{1})?$`)
var str = `+7 900 000 00 00`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}