import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<id>\\/f\\/\\d+\\/\\d+x\\d+\\/\\w+\\/[^\\/]+)\\/?(?<modifiers>m\\/?(?<crop>\\d+x\\d+:\\d+x\\d+)?\\/?(?<resize>(?<width>\\-?\\d+)x(?<height>\\-?\\d+))?\\/?(?<filters>filters\\:[^\\/]+)?)?$";
final String string = "/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/100x100:450x350/200x200/filters:grayscale()\n"
+ "/f/39898/2250x1500/c15735a73c/demo-image-human.jpeg/m/600x130\n"
+ "/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/-230x230/filters:rotate(90)\n"
+ "/f/39898/1000x600/d962430746/demo-image-human.jpeg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}