const regex = /(?<id>\/f\/\d+\/\d+x\d+\/\w+\/[^\/]+)\/?(?<modifiers>m\/?(?<crop>\d+x\d+:\d+x\d+)?\/?(?<resize>(?<width>\-?\d+)x(?<height>\-?\d+))?\/?(?<filters>filters\:[^\/]+)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<id>\\\/f\\\/\\d+\\\/\\d+x\\d+\\\/\\w+\\\/[^\\\/]+)\\\/?(?<modifiers>m\\\/?(?<crop>\\d+x\\d+:\\d+x\\d+)?\\\/?(?<resize>(?<width>\\-?\\d+)x(?<height>\\-?\\d+))?\\\/?(?<filters>filters\\:[^\\\/]+)?)?$', 'gm')
const str = `/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/100x100:450x350/200x200/filters:grayscale()
/f/39898/2250x1500/c15735a73c/demo-image-human.jpeg/m/600x130
/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/-230x230/filters:rotate(90)
/f/39898/1000x600/d962430746/demo-image-human.jpeg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}