$re = '/(?<id>\/f\/\d+\/\d+x\d+\/\w+\/[^\/]+)\/?(?<modifiers>m\/?(?<crop>\d+x\d+:\d+x\d+)?\/?(?<resize>(?<width>\-?\d+)x(?<height>\-?\d+))?\/?(?<filters>filters\:[^\/]+)?)?$/m';
$str = '/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/100x100:450x350/200x200/filters:grayscale()
/f/39898/2250x1500/c15735a73c/demo-image-human.jpeg/m/600x130
/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/-230x230/filters:rotate(90)
/f/39898/1000x600/d962430746/demo-image-human.jpeg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);