# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[0-9])\s+(?=(?:st|[rn]d|th)(?: [^\W\d_]|$))//gm;t' <<< "10 th elementary
1 st grade
133 rd anniversary
abc123 th 33333 rddccc
10 thetree
20 street
"