using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[0-9])\s+(?=(?:st|[rn]d|th)(?: [^\W\d_]|$))";
string substitution = @"";
string input = @"10 th elementary
1 st grade
133 rd anniversary
abc123 th 33333 rddccc
10 thetree
20 street
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}