const regex = /(?<=[0-9])\s+(?=(?:st|[rn]d|th)(?: [^\W\d_]|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[0-9])\\s+(?=(?:st|[rn]d|th)(?: [^\\W\\d_]|$))', 'gm')
const str = `10 th elementary
1 st grade
133 rd anniversary
abc123 th 33333 rddccc
10 thetree
20 street
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);