use strict;
my $str = '10 th elementary
1 st grade
133 rd anniversary
abc123 th 33333 rddccc
10 thetree
20 street
';
my $regex = qr/(?<=[0-9])\s+(?=(?:st|[rn]d|th)(?: [^\W\d_]|$))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";