re = /(?<=[0-9])\s+(?=(?:st|[rn]d|th)(?: [^\W\d_]|$))/m
str = '10 th elementary
1 st grade
133 rd anniversary
abc123 th 33333 rddccc
10 thetree
20 street
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result