package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`".*?"(*SKIP)(*FAIL)|(\w+\s[<>@]\s\w+)`)
var str = `Neuman@BBN-TENEXA
Alfred > Neuman <Neuman@BBN-TENEXA>
Alfred > Neuman <Neuman@BBN-TENEXA>, Alfred Neuman <Neuman@BBN-TENEXA>, "Alfred > Neuman" <Neuman@BBN-TENEXA>, Alfred > Neuman <Neuman@BBN-TENEXA>
"Alfred > Neuman" <Neuman@BBN-TENEXA>
Alfred @ Neuman <Neuman@BBN-TENEXA>`
var substitution = ""$1""
fmt.Println(re.ReplaceAllString(str, substitution))
}