$re = '/^\(?\+?(?:\d{3})?\)?[-. ]?(?!(\d)\1{9})\d{10}$/m';
$str = '(+123)-1234567890
(+123)-1111111111
(+123)-9999999999
(+123) 1234567890
(123)-1234567890
-1234567890
1234567890
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);