import Foundation
let pattern = #"n't|'(?:ll|[vr]e|[msd])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"should've can't mustn't we'll"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \g<0>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)