# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\s+S(\d{2})E(\d{2})[\- ]+(.*)/$1,$2,$3,$4/gm;t' <<< "12 Monkeys S02E10 - Fatherland.txt
Colony S02E01 - Eleven Thirteen.txt
Prison Break S05E05 - Contingency.txt"