package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\s+S(\d{2})E(\d{2})[\- ]+(.*)`)
var str = `12 Monkeys S02E10 - Fatherland.txt
Colony S02E01 - Eleven Thirteen.txt
Prison Break S05E05 - Contingency.txt`
var substitution = "$1,$2,$3,$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}