const regex = /(.*)\s+S(\d{2})E(\d{2})[\- ]+(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\s+S(\\d{2})E(\\d{2})[\\- ]+(.*)', 'gm')
const str = `12 Monkeys S02E10 - Fatherland.txt
Colony S02E01 - Eleven Thirteen.txt
Prison Break S05E05 - Contingency.txt`;
const subst = `$1,$2,$3,$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);