import re
regex = re.compile(r"(.*)\s+S(\d{2})E(\d{2})[\- ]+(.*)", flags=re.MULTILINE)
test_str = ("12 Monkeys S02E10 - Fatherland.txt\n"
"Colony S02E01 - Eleven Thirteen.txt\n"
"Prison Break S05E05 - Contingency.txt")
subst = "$1,$2,$3,$4"
result = regex.sub(subst, test_str)
if result:
print(result)