const regex = /^(?:0*1)*(?:00)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:0*1)*(?:00)+$', 'gm')
const str = `0
1
00
01
010
0100
01000
110000
1100100
11001001
110010010
1100100100
10110010000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}