re = /^((?!xyz).)*1.*$/m
str = 'Anytext1 Anytext2 xyz Anytext1 xyz AnyText1 xyz
Anytext0 Anytext2 xyz AnyText1 xyz Anytext1 xyz AnyText1 xyz AnyText1 xyz
some text 1 xyz 1
some text with xyz 1 xyz 1 1
1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end