const regex = /^(?<startwort>AB[\w\d-]*\d[\w\d-]*)(?>\s*,\s*|\s+)(?<startplus>(?>AB[\w\d-]*\d[\w\d-]*(?>\s*,\s*|\s+))*)(?<vorwort>.*)\s+(?<zahl>\d+)\s+(?<wort>[a-zA-Z0-9_üöä]+)\s+(?<betrag>[\d.,]+)\s*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<startwort>AB[\\w\\d-]*\\d[\\w\\d-]*)(?>\\s*,\\s*|\\s+)(?<startplus>(?>AB[\\w\\d-]*\\d[\\w\\d-]*(?>\\s*,\\s*|\\s+))*)(?<vorwort>.*)\\s+(?<zahl>\\d+)\\s+(?<wort>[a-zA-Z0-9_üöä]+)\\s+(?<betrag>[\\d.,]+)\\s*$', '')
const str = `AB2001482 AB0783714, AB0783714-Q ABBILD NRRHLAT 10 XäZ 207,25`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}