$re = '/\$status(?:\[[^\]]+\])?[^\'"]*(?:\'\K(?:[^\']|\'\')+|"\K[^"]+)/m';
$str = '$status[\'Совершенно_новое\'] = \'Brand_new<<\'\' New\'\'>>New\'
$status[\'Совершенно_новое\'] = \'Brand_new<br>New\'
$status[\'2\'] = "Brand_new<<\' New\'>>New"
$status["3"] = "Brand_new<<\' New\'>>New"
$status[4] = "Brand_new<<\' New\'>>New"
$status[\'\'8\'\'] = "Brand_new<<\' New\'>>New"
$status[\'5\'] = \'Brand_new""<<\' New\'>>New\'
$status = \'Brand_new<<\'\' New\'\'>>New\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);