$re = '/(?=(?:.*\d){3})(?=(?:.*[a-z]){3})^[a-z\d]*$/m';
$str = 'abc123
a2v1c3
123agc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);