import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Match";
final String string = "Ⓜⓐⓣⓒⓗ\n"
+ "🅜🅐🅣🅒🅗\n"
+ "Match\n"
+ "𝐌𝐚𝐭𝐜𝐡\n"
+ "𝕸𝖆𝖙𝖈𝖍\n"
+ "𝑴𝒂𝒕𝒄𝒉\n"
+ "𝓜𝓪𝓽𝓬𝓱\n"
+ "𝕄𝕒𝕥𝕔𝕙\n"
+ "𝙼𝚊𝚝𝚌𝚑\n"
+ "𝖬𝖺𝗍𝖼𝗁\n"
+ "𝗠𝗮𝘁𝗰𝗵\n"
+ "𝙈𝙖𝙩𝙘𝙝\n"
+ "𝘔𝘢𝘵𝘤𝘩\n"
+ "⒨⒜⒯⒞⒣\n"
+ "🇲🇦🇹🇨🇭\n"
+ "🄼🄰🅃🄲🄷\n"
+ "🅼🅰🆃🅲🅷 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}