using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\[2\][^=]+?= "").*(?="")";
string input = @"[0]
1 string data =
[1]
1 string data = ""first spanish text""
[2]
1 string data = ""some text""
[0]
1 string data = ""
[1]
1 string data = ""another text in spanish""
[2]
1 string data = ""some text"" in english"" and ""other""
...
[2]
1 string data = ""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}