$re = '/^K(?!.*#.*#)(?:#?[0-9a-z]){1,3}#?\$$/m';
$str = 'Kabc$
Ka#bc$
K01#a$
K#1ab$
Ka1a#$
K#1a#$
Ka1ab$
Pattern starts with the letter K
Is followed by any number (0-9) or any letter (a-z) between 1 and 3 times.
The symbol # can exist 0 or 1 time, anywhere after the starting K.
The pattern must end with the symbol $.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);