# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@Template\("(.[^\(\:]*)?(?:\:)(.[^\(\:]*)?(?:\:)?(.[^\(\:]*)?"\)/@Template\("$1\/$2\/$3/g;t' <<< "@Template(\"Area:Local:delete.html.twig\")
@Template(\"Group:add.html.twig\")
@Templaty(\"Group:add.html.twig\")"