import Foundation
let pattern = #"@Template\("(.[^\(\:]*)?(?:\:)(.[^\(\:]*)?(?:\:)?(.[^\(\:]*)?"\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@Template("Area:Local:delete.html.twig")
@Template("Group:add.html.twig")
@Templaty("Group:add.html.twig")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@Template\("$1/$2/$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)