import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<dd>\\d*)\\-?(?<hh>\\d*)\\:?(?<mm>\\d*)\\:?(?<ss>\\d*)$";
final String string = "1-10:20:30\n\n"
+ "10:20:30\n\n"
+ "20:30";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}