$re = '/(?<![^.\s])\w+(?!\S)/m';
$str = 'test.output0 testx.output1 output3 testds.output2 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);