re = /(?<![^.\s])\w+(?!\S)/m
str = 'test.output0 testx.output1 output3 testds.output2 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end