const regex = /(?:([^1])(\d+\.))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:([^1])(\\d+\\.))', 'g')
const str = `1. abcde. 2. fghijk 15. asdasd 10000. dsfsdfsdfsd`;
const subst = `\n$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);