using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^where's the wiki";
string input = @"where's the wiki ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}