re = /^.*Total IDOCs processed: \K([^\s]+)/m
str = '2024 Sep 11 19:26:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15705 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW
2024 Sep 11 19:27:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15710 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW
2024 Sep 11 19:28:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15713 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end