#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=class=")\s?btn\s?(btn-)?(mini|small|large)?\s?(?=")"
Local $sString = "<button class="btn btn-mini" />" & @CRLF & _
"<button class="btn btn-small" />" & @CRLF & _
"<button class="btn btn-large"/>" & @CRLF & _
"<button class="btn"/>" & @CRLF & _
"<button class="btn "/>" & @CRLF & _
"<button class=" btn"/>" & @CRLF & _
"<button class="btn btn-mini btn-primary" />" & @CRLF & _
"<button class="btn btn-small btn-success" />" & @CRLF & _
"<button class="btn btn-large btn-info"/>" & @CRLF & _
"<button class="btn btn-error"/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")