# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(namespace FeedStore\.Stores\.EF\.Entities\.Master)(\r\n|\n)({)(\r\n|\n)\s+(public partial class )\s*(\w+)"
test_str = ("using System;\n"
"using System.Collections.Generic;\n\n"
"#nullable disable\n\n"
"namespace FeedStore.Stores.EF.Entities.Master\n"
"{\n"
" public partial class Admin\n"
" {\n"
" public int Id { get; set; }\n"
" public string Name { get; set; }\n"
" public string Alias { get; set; }\n"
" public int TenantId { get; set; }\n"
" public DateTime Created { get; set; }\n"
" public string CreatedBy { get; set; }\n"
" public DateTime? Modified { get; set; }\n"
" public string ModifiedBy { get; set; }\n"
" }\n"
"}\n")
subst = "using FeedStore.Stores.EF.Contracts;\\r\\n\\r\\n$1$2$3$4\\t$5$6 : IAuditableModified, IAuditableAdded"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.